My Jewelbot doesn't turn on anymore?


I left my Jewelbot on over night without leaving it connected to power to charge, and it was off in the morning. I left it on the USB connected both to my laptop and directly to power during the day, but it still isn’t turning on. (No LEDs blinking, just totally blank, nothing happens when I hold the button for 2 seconds).

Any tips? Thanks.


oh no! When you plug it in, and hit the button once, does anything happen?


It doesn’t seem responsive at all. D:

I have a 2nd one that I could open and play around with, but I wanted to give one to my best friend. xD


That’s awful. We will 100% replace it. If you give me your email addy or order number I’ll tech out with details.


I’m having the same problem here. I have two Jewelbots. I managed to get a simple program uploaded to both of them. Then, I tried to upload a second program to one and now it won’t turn on. Nothing happens when I plug it into the charger or hit either the magic button or the reset button. Any other ways to reset it?


Now my second one is in the same state too. :frowning:

When I attempted to upgrade the firmware on these the first time through, it said programming successful but then also displayed an error message. So on the second Jewelbot, I decided I’d try upgrading the firmware again now that it seems to be working.

I plugged it in to the PC. Four purple lights were flashing. I think I held the magic button for two seconds around this time and the lights went off. I set the COM port and switched the Arduino board setting to firmware update and hit upload. It failed to upload.

The Jewelbot now won’t light up anymore. I’ve tried combinations of the button, reset, while charged, etc.


Thank you, Aaron. Sorry for the trouble. Looking into this now.


To confirm, when you plug it in and hold down the magic button for two seconds what do you see?


Nothing happens.

I just rebooted my PC to make sure it wasn’t something weird with USB or anything. No change. I also tried plugging one into the wall charger, no lights or anything, even when buttons pressed.


Okay, we’d like to confirm the steps you took so we can replicate them in the office.

  1. Updated the bot’s firmware
  2. Uploaded first program : worked
  3. Uploaded second program : bot stopped reacting

Is that accurate?

Can you paste the sketch you uploaded into the forum? We’d love to get you a quick fix.


Hey Aaron, Can I bug you for the address associated to your order? In the meantime, we’re going to send you another bot while we try to diagnose.


I think the steps were:

  • Update firmware. I probably did this a few times because the error message about not being able to communicate with board that showed up after the update complete one.
  • Upload a sketch. On one of the Jewelbots, the sketch I used was just the initial sample blue one. On the other one that I have, I modified it to blink the lights in sequence. I’m at work now so I don’t have the actual sketch with me but it was dead simple.
  • Plug Jewelbot back in, try to update firmware via steps in prior message. I saw the purple lights pulse when initially plugged in but at some point, they went off and I can’t get them to go on again.


Hey @aaronl !

Before Jewelbots send you a replacement Jewelbot, I just wanted to go through some more possible troubleshooting to see if we can actually get it working!

If I’m understanding what you wrote in your earlier comments:

  • Updated firmware - firmware gave you error
  • Blue light program worked - 2nd program uploaded didn’t
  • Hit button for 2 seconds, set up port and board - failed to upload
  • Magic Button, charger, reset button - Jewelbot unresponsive

Okay, so I’m going to make some explanations and questions. Let me know if any of it helps or if you are still having problems! If you are, then please let us know and we will work on immediately replacing your Jewelbots!

  • Update firmware error
    As of right now, we are unclear why the Arduino IDE prints out orange error text. However, when this happened, did you notice if at the bottom it said
    "DFU upgrade took XXXXs
    Device programmed. "
    If so that, means your program was uploaded successfully, and you should not feel that there was an error. If there was a different kind of error, please share it with us!.

  • Blue light program worked. 2nd program didn’t.
    Can you please share what you tried to upload as your second program? Depending on what it is, it could be causing your Jewelbot to seem unresponsive. For example, if an LED was set to be on for 650000 seconds then your Jewelbot will literally make you wait the 11 minutes. If the program is also bugged upon upload, then it could also cause your Jewelbot to be stuck on the program without showing any response.

  • Hit button for 2 seconds, set up port and board - failed to upload
    When the Jewelbot is plugged in and the Magic Button is pressed for 2 seconds, the Jewelbot goes into Upload Mode, which allows it to accept any program from the Arduino IDE.
    This mode lasts for 2 minutes and will make your Jewelbot unresponsive for the entirety of this time. However, if you do not upload code while in the Upload Mode, you will receive an error about no data being on the serial port.

  • Magic Button, charger, reset button - Jewelbot unresponsive
    If your Jewelbot is plugged in and you are pressing the Magic Button, then again, it will go into Upload Mode which will make it unresponsive for 2 minutes. If you press the reset button, it should also put your Jewelbot into Upload Mode.

If the 2nd program you uploaded is actually causing your Jewelbot to bug out, then pressing the reset button allows you to upload new code to overwrite the wacky, defective code. Here, I suggest trying to reupload the working blue light code to see if you can get a response going again.

You can also try reuploading the firmware (selecting the Firmware Update board and uploading a blank sketch) to get back to Friendship Mode, which is the default program settings your Jewelbot has.

If none of these notes are helpful, then maybe your Jewelbot was bricked, in which case we will send a replacement.

Please let me know if any of this helped or if you have any more information to add. Otherwise, Jewelbots is happy to send you a replacement order. We do not want our customers to go long without a working Jewelbot of their own!


I have the exact same problem on both of my Jewelbots. I had different programs on them. One Jewelbot #1, it was the default blue program with the long sleep. On #2, I had modified it so it was something like { for (i = 1; i <= 4; i++) { led.on(i, blue, 1000); } }. This worked, although because I mistakenly assumed it was 1 indexed when it seems led.on is actually zero indexed, only three of the lights were blinking in sequence. Anyway, when I connected each of them to the PC, I was able to hold the magic button and they went into programming mode. I tried to upload something, I think it was the firmware update to one and a program to the other, and that’s when they became unresponsive. I’ve tried all combinations of the magic button and reset button, pressing, holding, both at the same time, etc. They remain 100% unresponsive. I even tried this morning, 24 hours later. I’ve tried rebooting my PC. They don’t even respond with a charging indicator either when I plug them into an outlet. The one indication that they’re detected at all is that when I plug them into a USB port, COM port 5 shows up for one of them, and when I plug the other in, COM port 6 (or another number, can’t remember) shows up. Seems to indicate that at least part of the chip is working.


Okay, since you emailed us your address earlier:

We would like to send you postage to send us your broken Jewelbots, so we may look into the issue.

We will also send you two replacement Jewelbots, so that you may have new ones to enjoy!


@MoosaderRachel The problem you’re having sounds a lot like one that I had. My siblings and I got a set of three Jewelbots, and since we got them three days ago we’ve had this happen with two of them. For us, pressing the factory reset button on the side of the bot fixed it. We had to re-pair the Jewelbot that we reset with both of the others, but other than that there were no difficulties and both have worked fine since then.


@aaronl I sent you an email! Please check it :slight_smile:


One of my bots does not turn on any more as well. My situation is similar as to @aaronl.

After I got my three-pack of Jewelbots and using them for a few days with my daughters, I wanted to upgrade the firmware. I did not do that before. I ran into similar issues as described in the post failed to upgrade target error is no data received on serial-port-not-able-to-proceed. I did got the message DFU upgrade took 46.5151560307s so I am convinced that it did upgrade the new firmware. But after that my bot never turned on.

I tried multiple things. Having the bot plugged in the computer, plugged in to a wall socket or not plugged in at all. Holding the button for a longer period or only pressing it shortly. Pressing the reset button. All to no avail.

Is there anything left for me to try in order to get this Jewelbot to power on again? I am reluctant to update the firmware of my other bots :worried:


@dvberkel I’m so sorry! That is stressful as I’m sure it took you time to update the bot and then to have it not work is frustrating. If you reach out to, we can replace it or refund you. Whatever is preferable.


Hi @sara, thanks for responding. I am not that stressed because I still have working bots for my daughters.

I will reach out to because I would rather have a working Jewelbot than money.

But the question still remains. Is there anything that I can do to diagnose the problem? What happened? Did I fry it? Can I update the firmware on the others? What can I do to help?